Breadcrumb NavXT 5.0.1

This is the first bug fix release of the 5.0 branch of Breadcrumb NavXT. There were several issues reported with the 5.0.0 release and most have been fixed in this release. An issue where the bcn_display_list() produced duplicate code attributes in the output. The settings page tabs’ style has been adjusted to fit better with WordPress 3.8′s reskinned admin area. Additionally, users will be warned if their settings will be overridden by a BCN_SETTINGS_* define. Finally, a few issues in the uninstaller caused by the change in plugin structure were fixed.

As always, you can grab the latest version of Breadcrumb NavXT from the Breadcrumb NavXT page. If you experience any issues with this version of Breadcrumb NavXT, please leave a comment on this post detailing the issue.

-John Havlik

[end of transmission, stay tuned]

8 thoughts on “Breadcrumb NavXT 5.0.1

  1. I have upgraded to the latest version – 5.0.1

    I am running the plugin on a multisite network running 2 sites.
    The structure of the two sites is as follows:
    maindomain.com
    site2.maindomain.com

    I’m getting the info message as follows:
    Warning: No BCN_SETTINGS_* define statement found, defaulting to BCN_SETTINGS_FAVOR_NETWORK.

    However, when I go to NavXT settings page in network | settings, only the post types in maindomain.com are shown, not the custom post types in site2.maindomain.com

    I am therefore unable to change the text which appears in the breadcrumb for any custom post types in site2.maindomain.com

    Can you tell me how I can edit these settings for that site please.

    Thank you

  2. Hi.
    I try to create a breadcrumb like this: http://www.redfactory.nl/themes/thebeautysalon/features/typography/

    where the current page is not shown in breadcrumb. Only way I found was to use display:none; on the last link in the breadcrumb witch was cleverly marked with the class .current-item.

    But this class seems to be missing on my custom post types, and is only present on my pages. I have customized the “post” post type, so I cant give you clear information on wherether it work here.

    Is it a bug, or a missing feature? Or maybe you could suggest a workaround, if it is not out of your support range.

    • Likely this is just a default settings issue, which I can correct in the next release. For the time being, check out the breadcrumb template setting for the CPT in question (in the WP admin area go to Settings > Breadcrumb NavXT and then select the Post Types tab). Make sure class="%type%" exists within the anchor part of the template for that CPT.

      -John Havlik

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>