Breadcrumb NavXT 5.2 and PHP5.2

Breadcrumb NavXT has maintained PHP5.2 compatibility ever since WordPress dropped PHP4 support about four years ago. However, the time has come to move past PHP5.2 and on to newer versions of the language.

Due to new features in the upgraded adminKit library, Breadcrumb NavXT 5.2 requires language features that are not available in PHP5.2. To complicate matters further, PHP5.2 is no longer available in the package manager for the Linux distribution I run on my testbed server. Thus, even if I wanted to maintain PHP5.2 compatibility, I have no easy means to test for it.

Lastly, PHP5.2 is no longer maintained by the PHP authors (PHP5.3 has the same issue). Therefore, Breadcrumb NavXT 5.2 requires PHP5.3 or newer and it is very likely that Breadcrumb NavXT 5.3 will require PHP5.4.

-John Havlik

[end of transmission, stay tuned]

2 thoughts on “Breadcrumb NavXT 5.2 and PHP5.2

Leave a Reply

Your email address will not be published. Required fields are marked *