Breadcrumb NavXT Paths 1.8.0

Update: This version has been pulled due to the identification of a critical bug for users running versions of Breadcrumb NavXT older than 7.0. An update (1.8.1) that fixes this issue will be released today.

Announcing the immediate availability of Breadcrumb NavXT Paths 1.8.0. This version introduces a new filter, bcn_paths_tax_use_query_var which provides a method for controlling the query variables associated with a taxonomy. Also in this release is a fix to a bug in term to page mapping that resulted in a PHP error. Lastly, this version is the first to support Breadcrumb NavXT 7.0.

Users with valid and activated license keys should receive an update notification within the WordPress dashboard and be able to use the update mechanism to update (just like with any plugin in the WordPress.org repository).

-John Havlik

7 thoughts on “Breadcrumb NavXT Paths 1.8.0

  1. This is the error thrown:

    2021-11-18T12:52:39+00:00 CRITICAL Uncaught Error: Class ‘mtekk\adminKit\adminKit’ not found in includes/adminKit/class-mtekk_adminkit_licensing.php:27
    Stack trace:
    #0 class.bcn_paths_admin.php(23): include()
    #1 bcn_paths.php(125): require_once(‘…’)
    #2 includes/class.mtekk_plugkit_extension.php(148): bcn_paths->admin_setup()
    #7 wp-config.php(181): require_once(‘includes/adminKit/class-mtekk_adminkit_licensing.php on line 27

    • I’m not sure how you’re getting that specific error, the line numbers don’t make sense/it sounds like the file was modified trying to work around the erronous die() statement in the code. The fix is removing the die() statement on line 84 of class.mtekk_plugkit_extension.php. I have tested this on Breadcrumb NavXT 6.6 and it appears to resolve the issue.

      -John Havlik

      • There has been no modification at all. I copied the error from the error log.
        This error was thrown when the front end rendered the single word as reported in first message. Do you know where that came from? Suggest you remove that code as I thought I had been hacked.

        • The part that doesn’t make sense is the error seems to indicate the code path being followed is for Breadcrumb NavXT 7.0, but Breadcrumb NavXT 7.0 is obviously not there (hence the error about missing classes). Beyond the die() statement that should not have been in 1.8.0, it works without error on Breadcrumb NavXT 7.0 and Breadcrumb NavXT 6.6 (I retested on both versions before issuing the 1.8.1 release).

          -John Havlik

          • I don’t know what to say. The plugins all came from your site and I have a license for Paths. I am not in the habit of reporting an error caused by me editing third party plugins. It is all working fine now though.

            Cheers

            Steve

Leave a Reply

Your email address will not be published. Required fields are marked *